Skip to content

Commit

Permalink
Update to 0.4.20
Browse files Browse the repository at this point in the history
Upstream changes:
Changes in 0.4-20 (2022-04-29)

    Remove check for Yahoo Finance cookies because the site no longer responds with a cookie, and that caused the connection attempt to fail. This affected getSymbols(), getDividends(), and getSplits(). Thanks to several users for reporting, and especially to @pverspeelt and @alihru for investigating potential fixes! #358

    Update getSymbols.yahooj() for changes to the web page. #312

    Add HL() and supporting functions. These are analogues to HLC(), OHLC(), etc.Thanks for Karl Gauvin for the nudge to implement them.

    Add adjusted close to getSymbols.tiingo() output. Thanks to Ethan Smith for the suggestion and patch! #289 #345

    Use a Date index for getSymbols.tiingo() daily data. Thanks to Ethan Smith for the report! #350

    Remove unneeded arguments to the getSymbols.tiingo() implementation. Thanks to Ethan Smith for the suggestion and patch! #343 #343

    Load dividends and splits data into the correct environment when the user provides a value for the env argument. The previous behavior always loaded the data into the environment the function was called from. Thanks to Stewart Wright for the report and patch! #33

    Make getOptionChain() return all the fields that Yahoo Finance provides. Thanks to Adam Childers (@rhizomatican) for the patch! #318 #336

    Add orats as a source for getOptionChain(). Thanks to Steve Bronder (@SteveBronder) for the suggestion and implementation! #325

    Improve the error message when getSymbols() cannot import data for a symbol because the symbol is not valid or does not have historical data. Thanks to Peter Carl for the report. #333

    Fix the getMetals() example in the documentation. The example section previously had an example of getFX(). Thanks to Gerhard Nachtmann

    for the report and patch! #330

    Fix getQuote() so it returns data when the ticker symbol contains an “&”. Thanks to @pankaj3009 for the report! #324

    Fix addMACD() when col is specified. Thanks to @nvalueanalytics for the report! #321

Changes in 0.4-18 (2020-11-29)

    Fix issues handling https:// in getSymbols.yahooj(). Thanks to @Lobo1981 and @tchevri for the reports and @ethanbsmith for the suggestion to move from XML to xml2. #310 #312

    Fix getSymbols.yahoo(), getDividends(), and getSplits() so they all handle download errors and retry again. Thanks for @helgasoft for the report on getSymbols.yahoo() and @msfsalla for the report on getDividends() and getSplits(). #307 #314

    Add implied volatility and last trade date to getOptionChain() output. Thanks to @hd2581 and @romanlelek for the reports. And thanks to @rjvelasquezm for noticing the error when lastTradeDate is NULL. #224 #304

    Fix getOptionChain() to throw a warning and return NULL for every expiry that doesn’t have data. #299

    Add “Defaults” handling to getQuote() and getQuote.yahoo(). Thanks to @ethanbsmith for the report. #291

    Add Bid and Ask fields to the output from getQuote(). Thanks to @jrburl for the report and PR. #302

    Fix “Defaults” to handle unexported function (e.g. getQuote.av(). Thanks to @helgasoft for the report. #316

    importDefaults() doesn’t call get() on vector with length > 1. Thanks to Kurt Hornik for the report. #319

Changes in 0.4-17 (2020-03-31)

    chartTheme() now works when quantmod is not attached. Thanks to Kurt Hornik for the report.

Changes in 0.4-16 (2020-03-08)

    Remove disk I/O from getSymbols() and getQuote(). This avoids any disk contention, and makes the implementation pattern more consistent with other functions that import data. Thanks to Ethan Smith suggestion and PR. #280 #281

    Make getQuote() robust to symbols without data, so it does not error if one or more symbols are not found. Also return quotes in the same order as the ‘Symbols’ argument. Thanks to Ethan Smith feature request and PR. #279 #282 #288

    Handle semicolon-delimited symbol string handling to main getQuote() function. This makes getQuote() consistent with getSymbols(). Thanks to Ethan Smith suggestion and PR. #284 #285

    Fix ex-dividend and pay date mapping. getQuote() returned the dividend pay date labeled as the ex-dividend date. Thanks to @matiasandina for the report. #287

    Fix Yahoo Finance split ratio. The delimiter changed from “/” to “:”. For example, a 2-for-1 split was 1/2 but is now “2:1”. Thanks to @helgasoft for the report. #292

    Error messages from getQuote.alphavantage() and getQuote.tiingo() no longer contain the API key when symbols can’t be found. #286

    Fix getQuote.alphavantage() by replacing the defunct batch quote request with a loop over the single quote request. Thanks to @helgasoft for the report and patch. #296

    Update getOptionChain() to handle empty volume or open interest Thank to @jrburl for the report and PR. #299 #300
  • Loading branch information
wen committed May 29, 2022
1 parent 61775a6 commit 4988213
Show file tree
Hide file tree
Showing 2 changed files with 6 additions and 6 deletions.
4 changes: 2 additions & 2 deletions finance/R-quantmod/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.4 2019/08/08 19:53:41 brook Exp $
# $NetBSD: Makefile,v 1.5 2022/05/29 00:04:50 wen Exp $

R_PKGNAME= quantmod
R_PKGVER= 0.4-15
R_PKGVER= 0.4.20
CATEGORIES= finance

MAINTAINER= minskim@NetBSD.org
Expand Down
8 changes: 4 additions & 4 deletions finance/R-quantmod/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.4 2021/10/26 10:26:00 nia Exp $
$NetBSD: distinfo,v 1.5 2022/05/29 00:04:50 wen Exp $

BLAKE2s (R/quantmod_0.4-15.tar.gz) = 4f08484228e2a0b247250f60fc250a72a7f7617be43aad9ef3dfd78f50e72b09
SHA512 (R/quantmod_0.4-15.tar.gz) = 7352e10b9f101ff9725e8d8540515c93f158e5b0c20adb6d99611efbcc1bc6b291b19278c09051756407b9eb3db8736e5183cbf15494f2a0e4d87b51dcacce97
Size (R/quantmod_0.4-15.tar.gz) = 150327 bytes
BLAKE2s (R/quantmod_0.4.20.tar.gz) = d13d955fb0b5f1014fc92bf5cd776e0a0c137e231c6ffe7a250a99fe2be6362e
SHA512 (R/quantmod_0.4.20.tar.gz) = 27b0c31eb42a82c79be2a32b0bf59e3ce3c8c0463eca3709e3a82b8dbde500f58d5b21babe2116ab5b44df0ab41c2addfa709c4732e5e84671d94e16804794f7
Size (R/quantmod_0.4.20.tar.gz) = 156640 bytes

0 comments on commit 4988213

Please sign in to comment.