Skip to content

Commit

Permalink
textproc/ripgrep: update to 14.0.2
Browse files Browse the repository at this point in the history
14.0.2 (2023-11-27)
===================
This is a patch release with a few small bug fixes.

Bug fixes:

* [BUG #2654](BurntSushi/ripgrep#2654):
  Fix `deb` release sha256 sum file.
* [BUG #2658](BurntSushi/ripgrep#2658):
  Fix partial regression in the behavior of `--null-data --line-regexp`.
* [BUG #2659](BurntSushi/ripgrep#2659):
  Fix Fish shell completions.
* [BUG #2662](BurntSushi/ripgrep#2662):
  Fix typo in documentation for `-i/--ignore-case`.


14.0.1 (2023-11-26)
===================
This a patch release meant to fix `cargo install ripgrep` on Windows.

Bug fixes:

* [BUG #2653](BurntSushi/ripgrep#2653):
  Include `pkg/windows/Manifest.xml` in crate package.


14.0.0 (2023-11-26)
===================
ripgrep 14 is a new major version release of ripgrep that has some new
features, performance improvements and a lot of bug fixes.

The headlining feature in this release is hyperlink support. In this release,
they are an opt-in feature but may change to an opt-out feature in the future.
To enable them, try passing `--hyperlink-format default`. If you use [VS Code],
then try passing `--hyperlink-format vscode`. Please [report your experience
with hyperlinks][report-hyperlinks], positive or negative.

[VS Code]: https://code.visualstudio.com/
[report-hyperlinks]: BurntSushi/ripgrep#2611

Another headlining development in this release is that it contains a rewrite
of its regex engine. You generally shouldn't notice any changes, except for
some searches may get faster. You can read more about the [regex engine rewrite
on my blog][regex-internals]. Please [report your performance improvements or
regressions that you notice][report-perf].

[report-perf]: BurntSushi/ripgrep#2652

Finally, ripgrep switched the library it uses for argument parsing. Users
should not notice a difference in most cases (error messages have changed
somewhat), but flag overrides should generally be more consistent. For example,
things like `--no-ignore --ignore-vcs` work as one would expect (disables all
filtering related to ignore rules except for rules found in version control
systems such as `git`).

[regex-internals]: https://blog.burntsushi.net/regex-internals/

**BREAKING CHANGES**:

* `rg -C1 -A2` used to be equivalent to `rg -A2`, but now it is equivalent to
  `rg -B1 -A2`. That is, `-A` and `-B` no longer completely override `-C`.
  Instead, they only partially override `-C`.

Build process changes:

* ripgrep's shell completions and man page are now created by running ripgrep
with a new `--generate` flag. For example, `rg --generate man` will write a
man page in `roff` format on stdout. The release archives have not changed.
* The optional build dependency on `asciidoc` or `asciidoctor` has been
dropped. Previously, it was used to produce ripgrep's man page. ripgrep now
owns this process itself by writing `roff` directly.

Performance improvements:

* [PERF #1746](BurntSushi/ripgrep#1746):
  Make some cases with inner literals faster.
* [PERF #1760](BurntSushi/ripgrep#1760):
  Make most searches with `\b` look-arounds (among others) much faster.
* [PERF #2591](BurntSushi/ripgrep#2591):
  Parallel directory traversal now uses work stealing for faster searches.
* [PERF #2642](BurntSushi/ripgrep#2642):
  Parallel directory traversal has some contention reduced.

Feature enhancements:

* Added or improved file type filtering for Ada, DITA, Elixir, Fuchsia, Gentoo,
  Gradle, GraphQL, Markdown, Prolog, Raku, TypeScript, USD, V
* [FEATURE #665](BurntSushi/ripgrep#665):
  Add a new `--hyperlink-format` flag that turns file paths into hyperlinks.
* [FEATURE #1709](BurntSushi/ripgrep#1709):
  Improve documentation of ripgrep's behavior when stdout is a tty.
* [FEATURE #1737](BurntSushi/ripgrep#1737):
  Provide binaries for Apple silicon.
* [FEATURE #1790](BurntSushi/ripgrep#1790):
  Add new `--stop-on-nonmatch` flag.
* [FEATURE #1814](BurntSushi/ripgrep#1814):
  Flags are now categorized in `-h/--help` output and ripgrep's man page.
* [FEATURE #1838](BurntSushi/ripgrep#1838):
  An error is shown when searching for NUL bytes with binary detection enabled.
* [FEATURE #2195](BurntSushi/ripgrep#2195):
  When `extra-verbose` mode is enabled in zsh, show extra file type info.
* [FEATURE #2298](BurntSushi/ripgrep#2298):
  Add instructions for installing ripgrep using `cargo binstall`.
* [FEATURE #2409](BurntSushi/ripgrep#2409):
  Added installation instructions for `winget`.
* [FEATURE #2425](BurntSushi/ripgrep#2425):
  Shell completions (and man page) can be created via `rg --generate`.
* [FEATURE #2524](BurntSushi/ripgrep#2524):
  The `--debug` flag now indicates whether stdin or `./` is being searched.
* [FEATURE #2643](BurntSushi/ripgrep#2643):
  Make `-d` a short flag for `--max-depth`.
* [FEATURE #2645](BurntSushi/ripgrep#2645):
  The `--version` output will now also contain PCRE2 availability information.

Bug fixes:

* [BUG #884](BurntSushi/ripgrep#884):
  Don't error when `-v/--invert-match` is used multiple times.
* [BUG #1275](BurntSushi/ripgrep#1275):
  Fix bug with `\b` assertion in the regex engine.
* [BUG #1376](BurntSushi/ripgrep#1376):
  Using `--no-ignore --ignore-vcs` now works as one would expect.
* [BUG #1622](BurntSushi/ripgrep#1622):
  Add note about error messages to `-z/--search-zip` documentation.
* [BUG #1648](BurntSushi/ripgrep#1648):
  Fix bug where sometimes short flags with values, e.g., `-M 900`, would fail.
* [BUG #1701](BurntSushi/ripgrep#1701):
  Fix bug where some flags could not be repeated.
* [BUG #1757](BurntSushi/ripgrep#1757):
  Fix bug when searching a sub-directory didn't have ignores applied correctly.
* [BUG #1891](BurntSushi/ripgrep#1891):
  Fix bug when using `-w` with a regex that can match the empty string.
* [BUG #1911](BurntSushi/ripgrep#1911):
  Disable mmap searching in all non-64-bit environments.
* [BUG #1966](BurntSushi/ripgrep#1966):
  Fix bug where ripgrep can panic when printing to stderr.
* [BUG #2046](BurntSushi/ripgrep#2046):
  Clarify that `--pre` can accept any kind of path in the documentation.
* [BUG #2108](BurntSushi/ripgrep#2108):
  Improve docs for `-r/--replace` syntax.
* [BUG #2198](BurntSushi/ripgrep#2198):
  Fix bug where `--no-ignore-dot` would not ignore `.rgignore`.
* [BUG #2201](BurntSushi/ripgrep#2201):
  Improve docs for `-r/--replace` flag.
* [BUG #2288](BurntSushi/ripgrep#2288):
  `-A` and `-B` now only each partially override `-C`.
* [BUG #2236](BurntSushi/ripgrep#2236):
  Fix gitignore parsing bug where a trailing `\/` resulted in an error.
* [BUG #2243](BurntSushi/ripgrep#2243):
  Fix `--sort` flag for values other than `path`.
* [BUG #2246](BurntSushi/ripgrep#2246):
  Add note in `--debug` logs when binary files are ignored.
* [BUG #2337](BurntSushi/ripgrep#2337):
  Improve docs to mention that `--stats` is always implied by `--json`.
* [BUG #2381](BurntSushi/ripgrep#2381):
  Make `-p/--pretty` override flags like `--no-line-number`.
* [BUG #2392](BurntSushi/ripgrep#2392):
  Improve global git config parsing of the `excludesFile` field.
* [BUG #2418](BurntSushi/ripgrep#2418):
  Clarify sorting semantics of `--sort=path`.
* [BUG #2458](BurntSushi/ripgrep#2458):
  Make `--trim` run before `-M/--max-columns` takes effect.
* [BUG #2479](BurntSushi/ripgrep#2479):
  Add documentation about `.ignore`/`.rgignore` files in parent directories.
* [BUG #2480](BurntSushi/ripgrep#2480):
  Fix bug when using inline regex flags with `-e/--regexp`.
* [BUG #2505](BurntSushi/ripgrep#2505):
  Improve docs for `--vimgrep` by mentioning footguns and some work-arounds.
* [BUG #2519](BurntSushi/ripgrep#2519):
  Fix incorrect default value in documentation for `--field-match-separator`.
* [BUG #2523](BurntSushi/ripgrep#2523):
  Make executable searching take `.com` into account on Windows.
* [BUG #2574](BurntSushi/ripgrep#2574):
  Fix bug in `-w/--word-regexp` that would result in incorrect match offsets.
* [BUG #2623](BurntSushi/ripgrep#2623):
  Fix a number of bugs with the `-w/--word-regexp` flag.
* [BUG #2636](BurntSushi/ripgrep#2636):
  Strip release binaries for macOS.
  • Loading branch information
0323pin committed Nov 28, 2023
1 parent 620c342 commit 3d89a00
Show file tree
Hide file tree
Showing 3 changed files with 179 additions and 207 deletions.
4 changes: 2 additions & 2 deletions textproc/ripgrep/Makefile
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.19 2023/05/17 21:46:46 wiz Exp $
# $NetBSD: Makefile,v 1.20 2023/11/28 10:12:28 pin Exp $

DISTNAME= ripgrep-13.0.0
DISTNAME= ripgrep-14.0.2
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_GITHUB:=BurntSushi/}

Expand Down
95 changes: 44 additions & 51 deletions textproc/ripgrep/cargo-depends.mk
Original file line number Diff line number Diff line change
@@ -1,58 +1,51 @@
# $NetBSD: cargo-depends.mk,v 1.2 2021/06/12 17:15:29 pin Exp $
# $NetBSD: cargo-depends.mk,v 1.3 2023/11/28 10:12:28 pin Exp $

CARGO_CRATE_DEPENDS+= aho-corasick-0.7.18
CARGO_CRATE_DEPENDS+= atty-0.2.14
CARGO_CRATE_DEPENDS+= base64-0.13.0
CARGO_CRATE_DEPENDS+= bitflags-1.2.1
CARGO_CRATE_DEPENDS+= bstr-0.2.16
CARGO_CRATE_DEPENDS+= bytecount-0.6.2
CARGO_CRATE_DEPENDS+= cc-1.0.68
CARGO_CRATE_DEPENDS+= cfg-if-0.1.10
CARGO_CRATE_DEPENDS+= aho-corasick-1.1.2
CARGO_CRATE_DEPENDS+= anyhow-1.0.75
CARGO_CRATE_DEPENDS+= autocfg-1.1.0
CARGO_CRATE_DEPENDS+= bstr-1.8.0
CARGO_CRATE_DEPENDS+= cc-1.0.83
CARGO_CRATE_DEPENDS+= cfg-if-1.0.0
CARGO_CRATE_DEPENDS+= clap-2.33.3
CARGO_CRATE_DEPENDS+= crossbeam-channel-0.5.1
CARGO_CRATE_DEPENDS+= crossbeam-utils-0.8.5
CARGO_CRATE_DEPENDS+= encoding_rs-0.8.28
CARGO_CRATE_DEPENDS+= crossbeam-channel-0.5.8
CARGO_CRATE_DEPENDS+= crossbeam-deque-0.8.3
CARGO_CRATE_DEPENDS+= crossbeam-epoch-0.9.15
CARGO_CRATE_DEPENDS+= crossbeam-utils-0.8.16
CARGO_CRATE_DEPENDS+= encoding_rs-0.8.33
CARGO_CRATE_DEPENDS+= encoding_rs_io-0.1.7
CARGO_CRATE_DEPENDS+= fnv-1.0.7
CARGO_CRATE_DEPENDS+= fs_extra-1.2.0
CARGO_CRATE_DEPENDS+= glob-0.3.0
CARGO_CRATE_DEPENDS+= hermit-abi-0.1.18
CARGO_CRATE_DEPENDS+= itoa-0.4.7
CARGO_CRATE_DEPENDS+= jemalloc-sys-0.3.2
CARGO_CRATE_DEPENDS+= jemallocator-0.3.2
CARGO_CRATE_DEPENDS+= jobserver-0.1.22
CARGO_CRATE_DEPENDS+= lazy_static-1.4.0
CARGO_CRATE_DEPENDS+= libc-0.2.97
CARGO_CRATE_DEPENDS+= libm-0.1.4
CARGO_CRATE_DEPENDS+= log-0.4.14
CARGO_CRATE_DEPENDS+= memchr-2.4.0
CARGO_CRATE_DEPENDS+= memmap2-0.3.0
CARGO_CRATE_DEPENDS+= num_cpus-1.13.0
CARGO_CRATE_DEPENDS+= once_cell-1.7.2
CARGO_CRATE_DEPENDS+= packed_simd_2-0.3.5
CARGO_CRATE_DEPENDS+= pcre2-0.2.3
CARGO_CRATE_DEPENDS+= pcre2-sys-0.2.5
CARGO_CRATE_DEPENDS+= pkg-config-0.3.19
CARGO_CRATE_DEPENDS+= proc-macro2-1.0.27
CARGO_CRATE_DEPENDS+= quote-1.0.9
CARGO_CRATE_DEPENDS+= regex-1.5.4
CARGO_CRATE_DEPENDS+= regex-automata-0.1.10
CARGO_CRATE_DEPENDS+= regex-syntax-0.6.25
CARGO_CRATE_DEPENDS+= ryu-1.0.5
CARGO_CRATE_DEPENDS+= glob-0.3.1
CARGO_CRATE_DEPENDS+= itoa-1.0.9
CARGO_CRATE_DEPENDS+= jemalloc-sys-0.5.4+5.3.0-patched
CARGO_CRATE_DEPENDS+= jemallocator-0.5.4
CARGO_CRATE_DEPENDS+= jobserver-0.1.27
CARGO_CRATE_DEPENDS+= lexopt-0.3.0
CARGO_CRATE_DEPENDS+= libc-0.2.150
CARGO_CRATE_DEPENDS+= libm-0.2.8
CARGO_CRATE_DEPENDS+= log-0.4.20
CARGO_CRATE_DEPENDS+= memchr-2.6.4
CARGO_CRATE_DEPENDS+= memmap2-0.9.0
CARGO_CRATE_DEPENDS+= memoffset-0.9.0
CARGO_CRATE_DEPENDS+= num-traits-0.2.17
CARGO_CRATE_DEPENDS+= packed_simd-0.3.9
CARGO_CRATE_DEPENDS+= pcre2-0.2.6
CARGO_CRATE_DEPENDS+= pcre2-sys-0.2.7
CARGO_CRATE_DEPENDS+= pkg-config-0.3.27
CARGO_CRATE_DEPENDS+= proc-macro2-1.0.70
CARGO_CRATE_DEPENDS+= quote-1.0.33
CARGO_CRATE_DEPENDS+= regex-1.10.2
CARGO_CRATE_DEPENDS+= regex-automata-0.4.3
CARGO_CRATE_DEPENDS+= regex-syntax-0.8.2
CARGO_CRATE_DEPENDS+= ryu-1.0.15
CARGO_CRATE_DEPENDS+= same-file-1.0.6
CARGO_CRATE_DEPENDS+= serde-1.0.126
CARGO_CRATE_DEPENDS+= serde_derive-1.0.126
CARGO_CRATE_DEPENDS+= serde_json-1.0.64
CARGO_CRATE_DEPENDS+= strsim-0.8.0
CARGO_CRATE_DEPENDS+= syn-1.0.73
CARGO_CRATE_DEPENDS+= termcolor-1.1.2
CARGO_CRATE_DEPENDS+= textwrap-0.11.0
CARGO_CRATE_DEPENDS+= thread_local-1.1.3
CARGO_CRATE_DEPENDS+= unicode-width-0.1.8
CARGO_CRATE_DEPENDS+= unicode-xid-0.2.2
CARGO_CRATE_DEPENDS+= walkdir-2.3.2
CARGO_CRATE_DEPENDS+= scopeguard-1.2.0
CARGO_CRATE_DEPENDS+= serde-1.0.193
CARGO_CRATE_DEPENDS+= serde_derive-1.0.193
CARGO_CRATE_DEPENDS+= serde_json-1.0.108
CARGO_CRATE_DEPENDS+= syn-2.0.39
CARGO_CRATE_DEPENDS+= termcolor-1.4.0
CARGO_CRATE_DEPENDS+= textwrap-0.16.0
CARGO_CRATE_DEPENDS+= unicode-ident-1.0.12
CARGO_CRATE_DEPENDS+= walkdir-2.4.0
CARGO_CRATE_DEPENDS+= winapi-0.3.9
CARGO_CRATE_DEPENDS+= winapi-i686-pc-windows-gnu-0.4.0
CARGO_CRATE_DEPENDS+= winapi-util-0.1.5
CARGO_CRATE_DEPENDS+= winapi-util-0.1.6
CARGO_CRATE_DEPENDS+= winapi-x86_64-pc-windows-gnu-0.4.0
Loading

0 comments on commit 3d89a00

Please sign in to comment.