Skip to content

Commit

Permalink
node_exporter: Update to 1.3.1
Browse files Browse the repository at this point in the history
Changes:
## 1.3.1 / 2021-12-01

* [BUGFIX] Handle nil CPU thermal power status on M1
* [BUGFIX] bsd: Ignore filesystems flagged as MNT_IGNORE.
* [BUGFIX] Sanitize UTF-8 in dmi collector

## 1.3.0 / 2021-10-20

NOTE: In order to support globs in the textfile collector path, filenames exposed by
      `node_textfile_mtime_seconds` now contain the full path name.

* [CHANGE] Add path label to rapl collector
* [CHANGE] Exclude filesystems under /run/credentials
* [CHANGE] Add TCPTimeouts to netstat default filter
* [FEATURE] Add lnstat collector for metrics from /proc/net/stat/
* [FEATURE] Add darwin powersupply collector
* [FEATURE] Add support for monitoring GPUs on Linux
* [FEATURE] Add Darwin thermal collector
* [FEATURE] Add os release collector
* [FEATURE] Add netdev.address-info collector
* [FEATURE] Add clocksource metrics to time collector
* [ENHANCEMENT] Support glob textfile collector directories
* [ENHANCEMENT] ethtool: Expose node_ethtool_info metric
* [ENHANCEMENT] Use include/exclude flags for ethtool filtering
* [ENHANCEMENT] Add flag to disable guest CPU metrics
* [ENHANCEMENT] Add DMI collector
* [ENHANCEMENT] Add threads metrics to processes collector
* [ENHANCMMENT] Reduce timer GC delays in the Linux filesystem collector
* [ENHANCMMENT] Add TCPTimeouts to netstat default filter
* [ENHANCMMENT] Use SysctlTimeval for boottime collector on BSD
* [BUGFIX] ethtool: Sanitize metric names
* [BUGFIX] Fix ethtool collector for multiple interfaces
* [BUGFIX] Fix possible panic on macOS
* [BUGFIX] Collect flag_info and bug_info only for one core
* [BUGFIX] Prevent duplicate ethtool metric names

## 1.2.2 / 2021-08-06

* [BUGFIX] Fix processes collector long int parsing

## 1.2.1 / 2021-07-23

* [BUGFIX] Fix zoneinfo parsing prometheus/procfs#386
* [BUGFIX] Fix nvme collector log noise
* [BUGFIX] Fix rapl collector log noise

## 1.2.0 / 2021-07-15

NOTE: Ignoring invalid network speed will be the default in 2.x
NOTE: Filesystem collector flags have been renamed. `--collector.filesystem.ignored-mount-points` is now `--collector.filesystem.mount-points-exclude` and `--collector.filesystem.ignored-fs-types` is now `--collector.filesystem.fs-types-exclude`. The old flags will be removed in 2.x.

* [CHANGE] Rename filesystem collector flags to match other collectors
* [CHANGE] Make node_exporter print usage to STDOUT
* [FEATURE] Add conntrack statistics metrics
* [FEATURE] Add ethtool stats collector
* [FEATURE] Add flag to ignore network speed if it is unknown
* [FEATURE] Add tapestats collector for Linux
* [FEATURE] Add nvme collector
* [ENHANCEMENT] Add ErrorLog plumbing to promhttp
* [ENHANCEMENT] Add more Infiniband counters
* [ENHANCEMENT] netclass: retrieve interface names and filter before parsing
* [ENHANCEMENT] Add time zone offset metric
* [BUGFIX] Handle errors from disabled PSI subsystem
* [BUGFIX] Fix panic when using backwards compatible flags
* [BUGFIX] Fix wrong value for OpenBSD memory buffer cache
* [BUGFIX] Only initiate collectors once
* [BUGFIX] Handle small backwards jumps in CPU idle

## 1.1.2 / 2021-03-05

* [BUGFIX] Handle errors from disabled PSI subsystem
* [BUGFIX] Sanitize strings from /sys/class/power_supply
* [BUGFIX] Silence missing netclass errors

## 1.1.1 / 2021-02-12

* [BUGFIX] Fix ineffassign issue
* [BUGFIX] Fix some noisy log lines

## 1.1.0 / 2021-02-05

NOTE: We have improved some of the flag naming conventions (PR #1743). The old names are
      deprecated and will be removed in 2.0. They will continue to work for backwards
      compatibility.

* [CHANGE] Improve filter flag names
* [CHANGE] Add btrfs and powersupplyclass to list of exporters enabled by default
* [FEATURE] Add fibre channel collector
* [FEATURE] Expose cpu bugs and flags as info metrics.
* [FEATURE] Add network_route collector
* [FEATURE] Add zoneinfo collector
* [ENHANCEMENT] Add more InfiniBand counters
* [ENHANCEMENT] Add flag to aggr ipvs metrics to avoid high cardinality metrics
* [ENHANCEMENT] Adding backlog/current queue length to qdisc collector
* [ENHANCEMENT] Include TCP OutRsts in netstat metrics
* [ENHANCEMENT] Add pool size to entropy collector
* [ENHANCEMENT] Remove CGO dependencies for OpenBSD amd64
* [ENHANCEMENT] bcache: add writeback_rate_debug stats
* [ENHANCEMENT] Add check state for mdadm arrays via node_md_state metric
* [ENHANCEMENT] Expose XFS inode statistics
* [ENHANCEMENT] Expose zfs zpool state
* [ENHANCEMENT] Added an ability to pass collector.supervisord.url via SUPERVISORD_URL environment variable
* [BUGFIX] filesystem_freebsd: Fix label values
* [BUGFIX] Fix various procfs parsing errors
* [BUGFIX] Handle no data from powersupplyclass
* [BUGFIX] udp_queues_linux.go: change upd to udp in two error strings
* [BUGFIX] Fix node_scrape_collector_success behaviour
* [BUGFIX] Fix NodeRAIDDegraded to not use a string rule expressions
* [BUGFIX] Fix node_md_disks state label from fail to failed
* [BUGFIX] Handle EPERM for syscall in timex collector
* [BUGFIX] bcache: fix typo in a metric name
* [BUGFIX] Fix XFS read/write stats (prometheus/procfs#343)
  • Loading branch information
iamleot committed Aug 19, 2022
1 parent b9e8062 commit 17a09ce
Show file tree
Hide file tree
Showing 2 changed files with 1,933 additions and 24 deletions.
29 changes: 9 additions & 20 deletions sysutils/node_exporter/Makefile
Original file line number Diff line number Diff line change
@@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.37 2022/08/12 20:38:08 bsiegert Exp $
# $NetBSD: Makefile,v 1.38 2022/08/19 08:39:39 leot Exp $

DISTNAME= node_exporter-1.0.1
DISTNAME= node_exporter-1.3.1
MASTER_SITES= ${MASTER_SITE_GITHUB:=prometheus/}
PKGREVISION= 21
CATEGORIES= sysutils
GITHUB_TAG= v${PKGVERSION_NOREV}

Expand All @@ -11,23 +10,13 @@ HOMEPAGE= https://github.com/prometheus/node_exporter
COMMENT= Prometheus exporter for hardware and OS metrics
LICENSE= apache-2.0

GO_DIST_BASE= ${DISTNAME}
GO_SRCPATH= github.com/prometheus/node_exporter
GO_BUILD_PATTERN+= -ldflags ' \
-X github.com/prometheus/common/version.Version=${PKGVERSION_NOREV} \
-X github.com/prometheus/common/version.Revision=${PKGREVISION} \
-X github.com/prometheus/common/version.Branch=${GITHUB_TAG}'
GO_BUILD_PATTERN+= .

NEXP_GO_FLAG_PREFIX= -X ${GO_SRCPATH}/vendor/${GO_SRCPATH:H}/common/version
NEXP_GO_FLAGS+= -s
NEXP_GO_FLAGS+= ${NEXP_GO_FLAG_PREFIX}.Version=${PKGVERSION_NOREV}
NEXP_GO_FLAGS+= ${NEXP_GO_FLAG_PREFIX}.Revision=${PKGREVISION}
NEXP_GO_FLAGS+= ${NEXP_GO_FLAG_PREFIX}.Branch=${GITHUB_TAG}
.include "go-modules.mk"

do-build:
${RUN} ${PKGSRC_SETENV} ${MAKE_ENV} \
${GO} build -ldflags "${NEXP_GO_FLAGS}" ${GO_BUILD_PATTERN}
${RUN} ${PKGSRC_SETENV} ${MAKE_ENV} \
${GO} install -ldflags "${NEXP_GO_FLAGS}" ${GO_BUILD_PATTERN}

do-install:
${INSTALL_PROGRAM} ${WRKDIR}/bin/node_exporter ${DESTDIR}${PREFIX}/bin

.include "../../lang/go/go-package.mk"
.include "../../lang/go/go-module.mk"
.include "../../mk/bsd.pkg.mk"
Loading

0 comments on commit 17a09ce

Please sign in to comment.