Skip to content

Commit

Permalink
www/ruby-rack: update to 3.1.0
Browse files Browse the repository at this point in the history
3.1.0 (2024-06-11)

Rack v3.1 is primarily a maintenance release that removes features
deprecated in Rack v3.0.  Alongside these removals, there are several
improvements to the Rack SPEC, mainly focused on enhancing input and output
handling.  These changes aim to make Rack more efficient and align better
with the requirements of server implementations and relevant HTTP
specifications.

SPEC Changes

* rack.input is now optional. (#1997, #2018, @ioquatix)
* PATH_INFO is now validated according to the HTTP/1.1 specification.
  (#2117, #2181, @ioquatix)
    - OPTIONS * is now accepted. (#2114, @doriantaylor)
* Introduce optional rack.protocol request and response header for handling
  connection upgrades.  (#1954, @ioquatix)

Added

* Introduce Rack::Multipart::MissingInputError for improved handling of
  missing input in #parse_multipart.  (#2018, @ioquatix)
* Introduce module Rack::BadRequest which is included in multipart and query
  parser errors.  (#2019, @ioquatix)
* Add .mjs MIME type (#2057, @axilleas)
* set_cookie_header utility now supports the partitioned cookie
  attribute. This is required by Chrome in some embedded contexts.  (#2131,
  @flavio-b)
* Introduce rack.early_hints for sending 103 Early Hints informational
  responses.  (#1831, @casperisfine, @jeremyevans)

Changed

* MIME type for JavaScript files (.js) changed from application/javascript
  to text/javascript (1bd0f15, @ioquatix)
* Update MIME types associated to .ttf, .woff, .woff2 and .otf extensions to
  use mondern font/* types.  (#2065, @davidstosik)
* Rack::Utils.escape_html is now delegated to CGI.escapeHTML. ' is escaped
  to #39; instead of #x27;.  (decimal vs hexadecimal) (#2099, @JunichiIto)
* Clarify use of @Buffered and only update content-length when
  Rack::Response#finish is invoked.  (#2149, @ioquatix)

Deprecated

* Deprecate automatic cache invalidation in Request#{GET,POST} (#2073,
  @jeremyevans)
* Only cookie keys that are not valid according to the HTTP specifications
  are escaped.  We are planning to deprecate this behaviour, so now a
  deprecation message will be emitted in this case.  In the future, invalid
  cookie keys may not be accepted.  (#2191, @ioquatix)
* Rack::Logger is deprecated. (#2197, @ioquatix)
* Add fallback lookup and deprecation warning for obsolete status symbols.
  (#2137, @wtn)

Removed

* Remove deprecated Rack::Auth::Digest with no replacement.  (#1966,
  @ioquatix)
* Remove deprecated Rack::Cascade::NotFound with no replacement.  (#1966,
  @ioquatix)
* Remove deprecated Rack::Chunked with no replacement. (#1966, @ioquatix)
* Remove deprecated Rack::File, use Rack::Files instead. (#1966, @ioquatix)
* Remove deprecated Rack::QueryParser key_space_limit parameter with no
  replacement.  (#1966, @ioquatix)
* Remove deprecated Rack::Response#header, use Rack::Response#headers
  instead.  (#1966, @ioquatix)
* Remove deprecated cookie methods from Rack::Utils: add_cookie_to_header,
  make_delete_cookie_header, add_remove_cookie_to_header.  (#1966,
  @ioquatix)
* Remove deprecated Rack::Utils::HeaderHash.  (#1966, @ioquatix)
* Remove deprecated Rack::VERSION, Rack::VERSION_STRING, Rack.version, use
  Rack.release instead.  (#1966, @ioquatix)
* Remove non-standard status codes 306, 509, & 510 and update descriptions
  for 413, 422, & 451.  (#2137, @wtn)
* Remove any dependency on transfer-encoding: chunked. (#2195, @ioquatix)

Fixed

* In Rack::Files, ignore the Range header if served file is 0 bytes.
  (#2159, [@zarqman])
  • Loading branch information
taca committed Jun 11, 2024
1 parent 040a900 commit 0a68580
Show file tree
Hide file tree
Showing 3 changed files with 8 additions and 14 deletions.
4 changes: 2 additions & 2 deletions www/ruby-rack/Makefile
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.41 2024/05/12 15:00:18 taca Exp $
# $NetBSD: Makefile,v 1.42 2024/06/11 15:14:43 taca Exp $

DISTNAME= rack-3.0.11
DISTNAME= rack-3.1.0
CATEGORIES= www

MAINTAINER= pkgsrc-users@NetBSD.org
Expand Down
10 changes: 2 additions & 8 deletions www/ruby-rack/PLIST
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.21 2023/01/04 15:23:35 taca Exp $
@comment $NetBSD: PLIST,v 1.22 2024/06/11 15:14:43 taca Exp $
${GEM_HOME}/cache/${GEM_NAME}.gem
${GEM_LIBDIR}/CHANGELOG.md
${GEM_LIBDIR}/CONTRIBUTING.md
Expand All @@ -9,15 +9,10 @@ ${GEM_LIBDIR}/lib/rack.rb
${GEM_LIBDIR}/lib/rack/auth/abstract/handler.rb
${GEM_LIBDIR}/lib/rack/auth/abstract/request.rb
${GEM_LIBDIR}/lib/rack/auth/basic.rb
${GEM_LIBDIR}/lib/rack/auth/digest.rb
${GEM_LIBDIR}/lib/rack/auth/digest/md5.rb
${GEM_LIBDIR}/lib/rack/auth/digest/nonce.rb
${GEM_LIBDIR}/lib/rack/auth/digest/params.rb
${GEM_LIBDIR}/lib/rack/auth/digest/request.rb
${GEM_LIBDIR}/lib/rack/bad_request.rb
${GEM_LIBDIR}/lib/rack/body_proxy.rb
${GEM_LIBDIR}/lib/rack/builder.rb
${GEM_LIBDIR}/lib/rack/cascade.rb
${GEM_LIBDIR}/lib/rack/chunked.rb
${GEM_LIBDIR}/lib/rack/common_logger.rb
${GEM_LIBDIR}/lib/rack/conditional_get.rb
${GEM_LIBDIR}/lib/rack/config.rb
Expand All @@ -28,7 +23,6 @@ ${GEM_LIBDIR}/lib/rack/deflater.rb
${GEM_LIBDIR}/lib/rack/directory.rb
${GEM_LIBDIR}/lib/rack/etag.rb
${GEM_LIBDIR}/lib/rack/events.rb
${GEM_LIBDIR}/lib/rack/file.rb
${GEM_LIBDIR}/lib/rack/files.rb
${GEM_LIBDIR}/lib/rack/head.rb
${GEM_LIBDIR}/lib/rack/headers.rb
Expand Down
8 changes: 4 additions & 4 deletions www/ruby-rack/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.39 2024/05/12 15:00:18 taca Exp $
$NetBSD: distinfo,v 1.40 2024/06/11 15:14:43 taca Exp $

BLAKE2s (rack-3.0.11.gem) = a6cc7c8f5f62cf8b6aa346b2b057a0310932fdab07f8941e4ae0819c1c9d3f2b
SHA512 (rack-3.0.11.gem) = 77ea51d2a1584f58396cb864f9895ec47f36febaaf9bb806ebdb52d105ace8cac1a93144ac9769efbe1fff66f5bac555c7b949f62627cb80984d2ea31704d995
Size (rack-3.0.11.gem) = 109056 bytes
BLAKE2s (rack-3.1.0.gem) = 79cd74732f45c447df092f6805de717d96ba2341e097107e416b479f246fa106
SHA512 (rack-3.1.0.gem) = 3f9b825977209966eebb5ebc95060331b534d734928e1cac4cf123c991e9a67058f3d3e687374841c6d72f60cf1d036731e4f2acf82f056e7e804eb071b7eac3
Size (rack-3.1.0.gem) = 110080 bytes

0 comments on commit 0a68580

Please sign in to comment.