Skip to content

Ebgp neighbor stuck in active state if multihop cli given before the update-source  #3264

Closed
@vijaykug

Description

@vijaykug

Please the issue detail below , this looks like CLI sequencing issue.

R5-----------------------R6
14.1.1.1                        14.1.1.2
lo(105.105.105.105)      ( 106.106.106.106)

R5 config :

router bgp 3
 neighbor 105.105.105.105 remote-as 2
 neighbor 105.105.105.105 ebgp-multihop 255
 neighbor 105.105.105.105 update-source 106.106.106.106
 rfp full-table-download off

R6 config:

router bgp 2
 neighbor 106.106.106.106 remote-as 3
 neighbor 106.106.106.106 ebgp-multihop 255
 neighbor 106.106.106.106 update-source 105.105.105.105
 rfp full-table-download off

In above config please note that ebgp-multihop cli is configure before the update source
when this config is applied Ebgp BGP session getting stuck in Active state , clear bgp also did not helped

If i change the sequence like below ( update source command first and ebgp-multihop at the end )
session coming up fine.

router bgp 2
 neighbor 106.106.106.106 remote-as 3
 neighbor 106.106.106.106 update-source 105.105.105.105
 neighbor 106.106.106.106 ebgp-multihop 255
 rfp full-table-download off

Logs during issue state , TCP connection itself failed

R5:

2018/10/30 00:52:11 BGP: 106.106.106.106 [FSM] BGP_Stop (Active->Idle), fd -1
2018/10/30 00:52:11 BGP: 106.106.106.106 went from Active to Idle
2018/10/30 00:52:12 BGP: 106.106.106.106 [FSM] Timer (start timer expire).
2018/10/30 00:52:12 BGP: 106.106.106.106 [FSM] BGP_Start (Idle->Connect), fd -1
2018/10/30 00:52:12 BGP: 106.106.106.106 [FSM] Waiting for NHT
2018/10/30 00:52:12 BGP: 106.106.106.106 went from Idle to Connect
2018/10/30 00:52:12 BGP: 106.106.106.106 [FSM] TCP_connection_open_failed (Connect->Active), fd -1
2018/10/30 00:52:12 BGP: 106.106.106.106 went from Connect to Active

R6:

2018/10/30 00:52:29 BGP: 105.105.105.105 [FSM] BGP_Stop (Active->Idle), fd -1
2018/10/30 00:52:29 BGP: 105.105.105.105 went from Active to Idle
2018/10/30 00:52:30 BGP: 105.105.105.105 [FSM] Timer (start timer expire).
2018/10/30 00:52:30 BGP: 105.105.105.105 [FSM] BGP_Start (Idle->Connect), fd -1
2018/10/30 00:52:30 BGP: 105.105.105.105 [FSM] Waiting for NHT
2018/10/30 00:52:30 BGP: 105.105.105.105 went from Idle to Connect
2018/10/30 00:52:30 BGP: 105.105.105.105 [FSM] TCP_connection_open_failed (Connect->Active), fd -1
2018/10/30 00:52:30 BGP: 105.105.105.105 went from Connect to Active

Full config of R5 and R6:-

R5 Config

frr defaults traditional
hostname dev
log syslog informational
no ipv6 forwarding
hostname R5
service integrated-vtysh-config
username cumulus nopassword
!
debug bgp neighbor-events
!
interface ens161
 ip address 13.1.1.2/24
!
interface ens192
 ip address 14.1.1.1/24
!
interface lo
 ip address 105.105.105.105/32
!
router bgp 2
 neighbor 106.106.106.106 remote-as 3
 neighbor 106.106.106.106 ebgp-multihop 255
 neighbor 106.106.106.106 update-source 105.105.105.105
 rfp full-table-download off
!
router ospf
 ospf router-id 105.105.105.105
 passive-interface lo
 network 13.1.1.0/24 area 0
 network 14.1.1.0/24 area 0
 network 105.105.105.105/32 area 0
!
line vty
!
End

R6 Config

hostname dev
log syslog informational
no ipv6 forwarding
hostname R6
service integrated-vtysh-config
username cumulus nopassword
!
debug bgp neighbor-events
debug bgp update-groups
debug bgp zebra
!
ip route 44.4.4.4/32 blackhole
ip route 44.44.4.4/32 blackhole
!
interface ens192
 ip address 14.1.1.2/24
!
interface lo
 ip address 106.106.106.106/32
!
router bgp 3
 neighbor 105.105.105.105 remote-as 2
 neighbor 105.105.105.105 ebgp-multihop 255
 neighbor 105.105.105.105 update-source 106.106.106.106
 rfp full-table-download off
!
router ospf
 ospf router-id 106.106.106.106
 passive-interface lo
 network 14.1.1.0/24 area 0
 network 106.106.106.106/32 area 0
!
ip prefix-list R6 seq 5 permit 27.0.0.0/8
ip prefix-list R6 seq 10 permit 27.0.0.0/8 le 32
!
route-map R6 permit 10
 match ip address prefix-list R6
!
line vty
!
end

Metadata

Metadata

Assignees

Labels

Type

No type

Projects

No projects

Milestone

No milestone

Relationships

None yet

Development

No branches or pull requests

Issue actions