You signed in with another tab or window. Reload to refresh your session.You signed out in another tab or window. Reload to refresh your session.You switched accounts on another tab or window. Reload to refresh your session.Dismiss alert
{{ message }}
This repository was archived by the owner on Apr 24, 2023. It is now read-only.
Repository navigation
This repository was archived by the owner on Apr 24, 2023. It is now read-only.
Hi, @11111000000 , thanks for the report.
Does the installation process well or any error occurs? And If you enter canner command, what's the error thrown? Thanks!
Thanks for the response, I found the reason is that nixos doesn't support executing binary files by default. You can see the official documentation here.
Here is the basic Dockerfile and canner.schema.js. But notice that the command canner script:serve is designed to preview the CMS when developing. The correct way to host Canner CMS is using canner script:deploy to deploy the schema and canner.cloud.js to our platform.
Please let me know whether this fit your needs, thanks!
Hi, @FeklistovGleb, since we are using webpack-dev-server in canner script:serve for developing, the problem relates to the option. So I will add it soon and Inform you after new CLI releases. Thanks.
Hi, @FeklistovGleb, since we are using webpack-dev-server in canner script:serve for developing, the problem relates to the option. So I will add it soon and Inform you after new CLI releases. Thanks.
@abz53378 How avoid this with current cli or we can use own cli?
Try using @canner/cli@2.6.3, you can use canner script:serve -d, --disable-host-check to ignore the host check. This option just a quick fix for the script:serve, we will support the static:build and start commands for production usage (#126 ) soon. There will be more options that I think can fit most needs.