This repository contains a collection of Arch Linux PKGBUILDs for 1usOS (ArchLinux-based), with support currently focused on AArch64 Platforms and SBCs, as well as a repository build system for building, mirroring and serving a pacman repository.
To keep each branch clean and easy to maintain, each branch serve different purpose.
The following branches contains our repository build system.
- main - This branch contains our repository build system and its configurations
The following branches contains PKGBUILDs of our pacman repositories.
-
rockchip - This branch stores PKGBUILDs for packages related to the Rockchip Platform
-
asahi - This branch stores PKGBUILDs for packages related to the Asahi Linux (Apple Silicon) Platform
-
raspberrypi - This branch stores PKGBUILDs for packages related to the Raspberry Pi Platform
The following branches contains PKGBUILDs of our pacman repositories.
-
1usOS - This branch stores PKGBUILDs for packages related to 1usOS Branding and 1usOS Experience
-
misc - This branch stores PKGBUILDs of useful packages that isn't available on the Arch Linux core/extra repository, or need to be modified for non x86-64 platform.
-
multilib - This branch stores PKGBUILDs of 32-bit packages
Disclaimer: This repository is experimental, some packages are unstable / not tested, DO NOT use this repository in production.
- The repository is updated at 00:00 UTC daily, as a result, there will be a few minutes downtime, so avoid using this repository at that time.
As every package in this repo is signed with our PGP key, you must trust the repo before attempting to install any package.
import our signing key:
sudo pacman-key --recv-keys B669E3B56B3DC918
sudo pacman-key --lsign B669E3B56B3DC918
If you encounter gpg signature issue, you may bypass / disable the signature by adding SigLevel = Never
to the repository configuration.
For example, edit your /etc/pacman.conf
like this:
[misc]
SigLevel = Never
Server = https://github.com/1usOS/PKGBUILDs/releases/download/$arch
Replace the following part of /etc/pacman.conf
using your favorite text editor:
#
# REPOSITORIES
# - can be defined here or included from another file
# - pacman will search repositories in the order defined here
# - local/custom mirrors can be added here or in separate files
# - repositories listed first will take precedence when packages
# have identical names, regardless of version number
# - URLs will have $repo replaced by the name of the current repo
# - URLs will have $arch replaced by the name of the architecture
#
# Repository entries are of the format:
# [repo-name]
# Server = ServerName
# Include = IncludePath
#
# The header [repo-name] is crucial - it must be present and
# uncommented to enable the repo.
#
# The testing repositories are disabled by default. To enable, uncomment the
# repo name header and Include lines. You can add preferred servers immediately
# after the header, and they will be used before the default mirrors.
#[1usOS]
#Server = https://github.com/1usOS/PKGBUILDs/releases/download/$arch
[misc]
Server = https://github.com/1usOS/PKGBUILDs/releases/download/$arch
[core]
Include = /etc/pacman.d/mirrorlist
[extra]
Include = /etc/pacman.d/mirrorlist
[rockchip]
Server = https://github.com/1usOS/PKGBUILDs/releases/download/$arch
#[multilib]
#Server = https://github.com/1usOS/PKGBUILDs/releases/download/$arch
# An example of a custom package repository. See the pacman manpage for
# tips on creating your own repositories.
#[custom]
#SigLevel = Optional TrustAll
#Server = file:///home/custompkgs
If you just want to build / install a single package, there are many ways you can do that:
For example we want to build mesa-panfrost-git
:
Method 1: Using ACU
Add the branch of this repository to ACU:
acu rem set rockchip https://github.com/kwankiu/PKGBUILDs --branch=rockchip
Fetch the repository:
acu update
Build and Install the package:
acu install mesa-panfrost-git
Method 2: Using AGR
Add the branch of this repository to AGR:
agr rem set rockchip https://github.com/kwankiu/PKGBUILDs.git --branch rockchip
Build and Install the package:
agr install mesa-panfrost-git
Simply clone this repository (and switch to the branch of the target pkgbuild):
git clone https://github.com/kwankiu/PKGBUILDs.git -b rockchip
Now cd to the PKGBUILD's source of the cloned repository:
cd PKGBUILDs/mesa-panfrost-git
Now (make sure you are using a user account instead of root) we can build and install the package with :
makepkg -si
OR build (without installing) the package:
makepkg -s
We can build multiple packages in a clean, fast and efficient way using ARB.
The main branch of this repository contains a simple build script (build.sh) that allows you to build a pacman repository easily from building the packages to signing the packages as well as adding them to a pacman db. Then you can simply upload the generated repo
directory to a hosting provider or GitHub release.
git clone https://github.com/kwankiu/PKGBUILDs.git
Now cd to the cloned repository:
cd PKGBUILDs
Add your private key to gpg (or create one if you dont already have a key): Notes: Enter your passphrase whenever prompted to do so.
gpg --import myprivkey.asc
Import your signing key to pacman if you haven't:
sudo pacman-key --recv-keys YOURKEY
sudo pacman-key --lsign YOURKEY
Edit build.sh
:
Replace
repo_name="experimental"
with your preferred repo name
repo_name="YOUR_REPO_NAME"
Edit build.sh
:
Uncomment the zst one and comment the xz one:
#repo-add -s -v -n ${repo_name}.db.tar.xz *.pkg.tar.xz
repo-add -s -v -n ${repo_name}.db.tar.xz *.pkg.tar.zst
You may also want to customize or use your own config yaml, ARB config yaml are documented here.
Make sure you have permission to run the build script:
sudo chmod +x build.sh
To build all packages (from all yaml) at once:
./build.sh
OR
To build packages from a specified yaml (for example rockchip.yaml
):
./build.sh rockchip
Once it is done, the repository are generated at the repo
directory, you can simply upload everything from the generated directory to a hosting provider or GitHub release.