-
Notifications
You must be signed in to change notification settings - Fork 0
/
Copy pathimakshat47_maxElement.cpp
113 lines (80 loc) · 2.19 KB
/
imakshat47_maxElement.cpp
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
/*
Mark and Toys
Input Format
The first line contains two integers, and , the number of priced toys and the amount Mark has to spend.
The next line contains space-separated integers
Constraints
A toy can't be bought multiple times.
Output Format
An integer that denotes the maximum number of toys Mark can buy for his son.
Sample Input
7 50
1 12 5 111 200 1000 10
Sample Output
4
*/
#include <bits/stdc++.h>
using namespace std;
vector<string> split_string(string);
// Complete the maximumToys function below.
int maximumToys(vector<int> prices, int k)
{
sort(prices.begin(), prices.end());
int i = 0;
while (k)
{
if ((k - prices[i]) > 0)
{
k -= prices[i];
++i;
}
else
break;
}
return i;
}
int main()
{
ofstream fout(getenv("OUTPUT_PATH"));
string nk_temp;
getline(cin, nk_temp);
vector<string> nk = split_string(nk_temp);
int n = stoi(nk[0]);
int k = stoi(nk[1]);
string prices_temp_temp;
getline(cin, prices_temp_temp);
vector<string> prices_temp = split_string(prices_temp_temp);
vector<int> prices(n);
for (int i = 0; i < n; i++)
{
int prices_item = stoi(prices_temp[i]);
prices[i] = prices_item;
}
int result = maximumToys(prices, k);
fout << result << "\n";
fout.close();
return 0;
}
vector<string> split_string(string input_string)
{
string::iterator new_end = unique(input_string.begin(), input_string.end(), [](const char &x, const char &y) {
return x == y and x == ' ';
});
input_string.erase(new_end, input_string.end());
while (input_string[input_string.length() - 1] == ' ')
{
input_string.pop_back();
}
vector<string> splits;
char delimiter = ' ';
size_t i = 0;
size_t pos = input_string.find(delimiter);
while (pos != string::npos)
{
splits.push_back(input_string.substr(i, pos - i));
i = pos + 1;
pos = input_string.find(delimiter, i);
}
splits.push_back(input_string.substr(i, min(pos, input_string.length()) - i + 1));
return splits;
}